vps:administration:centos-6-pma-install-issues

4.4.15. Проблемы с установкой phpMyAdmin в CentOS 6

В стандартных репозиториях CentOS 6 нет необходимого пакета phpMyAdmin.

Проблема решается добавлением дополнительных репозиториев через консоль, подключившись к серверу по SSH:

wget http://dl.fedoraproject.org/pub/epel/beta/6/i386/epel-release-6-5.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm epel-release-6*.rpm  
yum -y update

Если на сервере установлен ISPmanager, выполните в консоли команду:

/usr/local/ispmgr/sbin/pkgctl cache

Очистите кеш в браузере, перейдите в панель ISPmanager в раздел «Настройки сервера — Возможности» и установите данный пакет.

Если на сервере нет ISPmanager, для установки phpMyAdmin выполните:

yum install phpmyadmin

При изменении пароля для MySQL-сервера при входе в phpMyAdmin может появится такая ошибка: Исправить её можно, внеся в файл /usr/share/phpmyadmin/config.inc.php такие изменения:

  • vps/administration/centos-6-pma-install-issues.txt
  • Последние изменения: 2019/08/29 15:34
  • — karlov