hosting:htaccess:unsupported-options

Различия

Показаны различия между двумя версиями страницы.

Ссылка на это сравнение

Предыдущая версия справа и слева Предыдущая версия
Следующая версия
Предыдущая версия
hosting:htaccess:unsupported-options [2019/08/30 16:48]
karlov
hosting:htaccess:unsupported-options [2020/04/29 16:15] (текущий)
karlov
Строка 1: Строка 1:
 ====== 2.12.1. Неподдерживаемые параметры ====== ====== 2.12.1. Неподдерживаемые параметры ======
  
-Если при открытии сайта возникает ошибка 500, её причиной может быть наличие в файле ''[[hosting:htaccess|.htaccess]]'' неподдерживаемых параметров.+Если при открытии сайта возникает ошибка 500, её причиной может быть наличие в файле [[hosting:htaccess|.htaccess]] неподдерживаемых параметров.
  
-В данной ситуации следует проверить содержимое файла ''[[hosting:htaccess|.htaccess]]'' и при необходимости внести в него соответствующие правки:+В данной ситуации следует проверить содержимое файла [[hosting:htaccess|.htaccess]] и при необходимости внести в него соответствующие правки:
   * ''Options +FollowSymLinks'' — нужно заменить на ''Options +SymLinksIfOwnerMatch''.   * ''Options +FollowSymLinks'' — нужно заменить на ''Options +SymLinksIfOwnerMatch''.
   * ''Options All -Indexes'' — нужно заменить на ''Options -Indexes''.   * ''Options All -Indexes'' — нужно заменить на ''Options -Indexes''.
   * ''+ExecCGI'' — нужно удалить.   * ''+ExecCGI'' — нужно удалить.
-  * ''AddHandler'' — нужно удалить. 
-  * ''php_value'' — нужно удалить. 
-  * ''php_flag'' — нужно удалить. 
-  * ''-MultiViews'' — нужно удалить. 
  
-На хостинге не используется модуль Apache ''mod_version'', поэтому если в ''[[hosting:htaccess|.htaccess]]'' присутствуют блоки с директивами ''IfVersion'', их также следует удалить, оставив только содержимое блоков, предназначенных для Apache 2.4.+На хостинге не используется модуль Apache ''mod_version'', поэтому если в [[hosting:htaccess|.htaccess]] присутствуют блоки с директивами ''IfVersion'', их также следует удалить, оставив только содержимое блоков, предназначенных для Apache 2.4.
  
 Также на хостинге нельзя использовать ''RewriteMap''. Если целью является, к примеру, преобразование URL в нижний регистр, решать эту задачу лучше с помощью добавления соответствующих директив непосредственно в PHP-скрипты сайта. Также на хостинге нельзя использовать ''RewriteMap''. Если целью является, к примеру, преобразование URL в нижний регистр, решать эту задачу лучше с помощью добавления соответствующих директив непосредственно в PHP-скрипты сайта.
  
 Для внесения изменений в файл можно использовать [[hosting:file-manager|файл-менеджер]] или любой [[hosting:ftp:clients|FTP-клиент]]. Для внесения изменений в файл можно использовать [[hosting:file-manager|файл-менеджер]] или любой [[hosting:ftp:clients|FTP-клиент]].
- 
-===== Другие статьи ===== 
- 
-{{indexmenu>.#1|nsort tsort}} 
  • hosting/htaccess/unsupported-options.1567172905.txt.gz
  • Последнее изменение: 2019/08/30 16:48
  • karlov